Chicago Timeouts
Incident Report for Tempest
Resolved
Chicago traffic seems to now be passing correctly. We are investigating an issue with a carrier.
Posted Dec 09, 2023 - 01:11 UTC
Investigating
We are currently investigating this issue.
Posted Dec 09, 2023 - 00:32 UTC
This incident affected: North America (Chicago, United States).