CH2 Outage
Incident Report for Tempest
Resolved
Equinix has completed maintenance
Posted Feb 28, 2024 - 21:42 UTC
Identified
Equinix is performing PDU maintenance on the Tempest upstream.
Posted Feb 28, 2024 - 07:50 UTC
This incident affected: Path Network and North America (Chicago, United States).